Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Failure to launch :(


Recommended Posts

My first game started with a white haze narrowing my vision to obscurity, couldn't navigate, and so far, my second launch is stuck in loading, says selecting character and never loaded into the match...

 

Good start... Also, the banners shown in the background on team select is not synchronized with the one chosen.

 

Oh, and I can't post on the test forum even though I'm accessing the game.

Edited by bahamutkaiser

a52d4a0d-044f-44ff-8a10-ccc31bfa2d87.jpg          Before you criticize someone, walk a mile in their shoes... Than if they're upset, they'll be a mile away, and barefoot :P

Link to comment
Share on other sites

I finally got into some games, let's see, there was a piece of armor stuck on my screen where it didn't move to my inventory, lasted through multiple matches.

 

I only played Centaur, his attacks automatically moved me forward, which made it difficult to maintain a position, a fatal dilemma when fighting on ramparts where falling off throws me out of position and incurs fall damage.

 

Aiming was terrible due to lag, turning jerked around and made it difficult to track evasive players, along with the attacks having poor feedback to confirm hits.

 

Powers had poor feedback, it was hard to feel when they were operating, and felt very floaty. They also wouldn't override standard attacks,

 

Hunger mist wasn't visible, I kept getting white out as it came near, but didn't see a visual indicator of where it was actually encroaching, making it difficult to avoid.

 

I was too preoccupied with acclimation to really assess the characters, and too uncertain about whether I'm experiencing unique problems or shared ones, personally, I don't think a PvP setting is a good environment to develop a benchmark. A barrack should be created for players to practice operating the archetypes and powers that way they know how to play or more importantly, inspect that the game is working right before combat.

 

Perhaps the stress testing impaired the gameplay, but I can't confirm that alone.

 

And, I still can't post on the tester forum, perhaps Alpha 3 hasn't been flagged as testers yet?

Edited by bahamutkaiser

a52d4a0d-044f-44ff-8a10-ccc31bfa2d87.jpg          Before you criticize someone, walk a mile in their shoes... Than if they're upset, they'll be a mile away, and barefoot :P

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...