Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't Play


Siv
 Share

Recommended Posts

Hello all!

I was gifted Crowfall by a friend last year. I was able to download and play the game on the servers during testing periods and once the live servers went up I was able to play on them as well. I haven't actively played the game in a couple months, but I would semi-regularly log in to select what I was passively leveling. However, about 3 weeks ago now when I launched the game I was greeted with a screen saying that I didn't have permission to play it. This struck me as odd because I had never seen that screen before and had previously accessed the game's content. I tried deleting Crowfall and reinstalling it, but when I went to download it again the download screen just said that I need to make sure I have the access from the store, but again I have played it before. I submitted a bug report a week or two ago, but haven't heard back. These are what I think are the relevant "items" attached to my account:

Beta Group 8; Beta 2; Play Test 2 Access Entitlement; Play Test 3 Participant; play-test-4; play-test-5; play-test-6; play-test-7; play-test-8; play-test-9; Digital Game Copy.

Is anyone else having this issue? Is there a solution that I haven't found?

Thanks in advance

Link to comment
Share on other sites

You said you submitted a bug report.  Was that an E-Mail to support@crowfall.com.

If not, do that. They usually get back very quickly, the whole "a week or two ago" seems to be a very odd thing if you sent in support emails.

Edited by KrakkenSmacken
Link to comment
Share on other sites

12 minutes ago, KrakkenSmacken said:

You said you submitted a bug report.  Was that an E-Mail to support@crowfall.com.

If not, do that. They usually get back very quickly, the whole "a week or two ago" seems to be a very odd thing if you sent in support emails.

No, I didn't email them, I used the bug report on the website. I'll try that, thanks!

Link to comment
Share on other sites

5 minutes ago, Siv said:

An update for those who care.

I emailed the support services, they responded to fix my issue in a very timely manner. Everything is working now.

Was it Gordon/Tyrant that got back to you?  That guy is a support machine for being so far up the food chain.

Link to comment
Share on other sites

Support should just sign all their emails as Gordon, even if the executive producer is no longer handling support. 

ACE team was clearly committed when someone that high up was answering emails at 2am.... That or team was just really damn small.  Great early PR.

Link to comment
Share on other sites

FYI, the "Need help" feature on the front page isn't working. It may appear that you've successfully sent in a report but, in truth, it gets shot out into the ether never to be seen again. I've contacted the Web team about it again to request that it be removed. I'm sorry for the confusion but glad to hear your issue has been resolved by our crackering Support crew. . 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...