Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Webpage Guild joining Issue


Recommended Posts

I applied for a guild on the guild forums here. I was later notified by the guild I applied to on their Guild Discord channel that after there Leadership review of my Application that the Guild LDR respectfully Denied my application.  OK, so I make a second choice and Join that Guilds Discord.  They ask me to go press the Join Guild option on the Official Crowfall forums... I try to but it says "I have already Applied,"...  The New Guild tells me their interface says  "We Invited you"... Yet when I go to Official Crowfall Forums and click the little white bell in the top right corner beside the Envelope and my Account NAME for notifications (the one right above this post)... It reads "THERE ARE NO NOTIFICATIONS TO DISPLAY "... So I seem to be left in Limbo. My Best assumption is maybe the guild LDR of guild #1 has to use some interface to Deny my application to free me up for another guild to recruit, but that is just me guessing.  Point being I found a Guild, they want me, they sent me an invite, but I am not getting it. I also tried logging out of game and logging in again just to see if I had a guild tab or something... That did not work.

 

Link to comment
Share on other sites

OK, New development. After I wrote this post I decided to try and click the Join guild icon again and I got a new message "Successfully Sent"... So now I am getting forward progress. Still no new Notifications though. Maybe it just takes a while or they need to accept again. I will wait and see...

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...