Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sicarious

Serious FPS issue, making the game unplayable.

Recommended Posts

I started playing like 3 weeks ago, and every thing was working great then all of a sudden my FPS tanked to 10, my internet is fine I was getting 30 to 50, then I wasn't. At first I was able to log out and back in and it work, I have tried other characters in other areas. Its all the same.

Share this post


Link to post
Share on other sites

I've had to work thru this same problem. several things to check:

- game settings - lower the better

- CPU meets minimum requirements

- overclock you CPU if it can be

- GPU meets minimum

set priority to run higher.

I've done all the above and get my Frame rates to 30-40+ during regular times, and 20+ during large combat


ShadowBane - Former IC of Societas Daemonica (2005 -2014)

ShadowBane - Former IC Nordic Chapter SB (2004)

ShadowBane -  Former IC / NL of House of Atreides, Damnation (2003-2004)

Share this post


Link to post
Share on other sites

It is possible that it is only the game. Everyone has problems with fps, but you have to know that it is pre-alpha. As a solution, you should minimize some graphic options so that the impacts are less.

Share this post


Link to post
Share on other sites

Welcome @Sicarious

If in doubt, there is always the option to contact support@crowfall.com (which up to now is more or less your direct line to the developers). Usually it's a problem on the users side. But often they can help you figuring out the issue, if the community can't.

Have fun, good luck and all the best.
Kraahk

Edited by Kraahk

Share this post


Link to post
Share on other sites

 @Sicarious ,

 Besides hardware being the issue, it could be another software program that is affecting Crowfall itself. The following programs have been known to slow down Crowfall so if you run any of these programs, I would try to disable them and then run crowfall again to see if anything improves.

-ASUS ROG Sonic Studio 2
-AMD Gaming Evolved / Raptr
-Overwolf
-Xfire
-PunkBuster
-FRAPS
-Plays.TV, Razer Cortex
-MSI Afterburner
-EVGA Precision X
-Razer Synapse 2.0
-ASUS Xonar Control Panel (for this program it's only necessary to disable GX Mode by opening the Control Panel, and de-selecting the GX/DX option

Share this post


Link to post
Share on other sites
On 1/28/2020 at 7:34 AM, Sicarious said:

I started playing like 3 weeks ago, and every thing was working great then all of a sudden my FPS tanked to 10, my internet is fine I was getting 30 to 50, then I wasn't. At first I was able to log out and back in and it work, I have tried other characters in other areas. Its all the same.

Running Ultra Wide, Ryzen 7 and 1080Ti Strix and getting about the same. The game is Alpha stage so UI and Graphic optimisation will come later, it's pretty much what you would expect with any game in Alpha/Beta stages. 

 

Share this post


Link to post
Share on other sites
On 1/28/2020 at 11:34 AM, Sicarious said:

I started playing like 3 weeks ago, and every thing was working great then all of a sudden my FPS tanked to 10, my internet is fine I was getting 30 to 50, then I wasn't. At first I was able to log out and back in and it work, I have tried other characters in other areas. Its all the same.

If fps suddenly drops, check if you are hitting memory limit (90%) and your OS starts swapping. If it happens, tune down graphics quality or install more RAM. Or may be you hit memory leak, then report it to support@crowfall.com.

Edited by ComradeAma

Share this post


Link to post
Share on other sites

thanks for the input guys. I have a pretty old rig, like 5 years old with 16gigs of ram, but a mediocre nvidia card. I am going to get a new one in a few days and see if that fixes things.

Share this post


Link to post
Share on other sites
On 1/30/2020 at 7:48 PM, Sicarious said:

thanks for the input guys. I have a pretty old rig, like 5 years old with 16gigs of ram, but a mediocre nvidia card. I am going to get a new one in a few days and see if that fixes things.

Please let me know if it helps, I've tried to play but at 10fps it is impossible. I've tried the suggestions that I've found but so far nothing has helped.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...